Subject: Request Handlers, please

From: "Carter Edwards : [email-masked]" <[email-masked]>
Date: Fri, 10 May 1996 12:44:08 -0500 (CDT)

Please post the minutes of the April 24-26, 1996 meeting.
The discussion and vote to remove Request Handlers from
the MPI2 spec. is of particular interest.

It was noted in Chapter 6, External Interfaces, that
Request Handlers will reappear in a TBD Chapter on Threads.

--

I propose that Request Handler semantics be "orthogonal"
to Thread semantics.  An MPI user should be able to
use Request Handlers without having to be concerned
with Thread semantics.

A simple suggestion to achieve this "orthogonality":
  If Threads are present, then the execution of a
  Request Handler preempts the Thread from which it
  was posted.  A Request Handler could either execute
  within its posting Thread or block its posting
  Thread until the Request Handler "returns".

If a MPI User wants a particular Handler or set of Handlers
to execute in a separate Thread then the MPI User must first
create a Thread and then post the Handler(s) within that Thread.

--

This baits a larger discussion regarding MPI-2 and Threads.
If an MPI implementation internally creates Threads then
should these threads:
  1) be transparent to the MPI user and 
  2) not introduce consistency problems in the
     presence of an MPI user's Threads.

----------------------------------------------------------------------------
Carter Edwards, [email-masked], http://www.ticam.utexas.edu/~carter
----------------------------------------------------------------------------

---

From: Anthony Skjellum <[email-masked]>
Date: Fri, 10 May 1996 14:53:38 -0500 (CDT)

Carter, there are MPI implementations that use threads inside.  They
should certainly be transparent to user process.  Windows/NT version
we are doing works this way.
-Tony

On Fri, 10 May 1996, Carter Edwards : [email-masked] wrote:

> Date: Fri, 10 May 1996 12:44:08 -0500 (CDT)
> From: Carter Edwards : [email-masked] <[email-masked]>
> To: [email-masked], [email-masked]
> Subject: Request Handlers, please
> 
> 

Anthony Skjellum, PhD, Asst. Professor of Computer Science; 
Mississippi State University, Department of Computer Science & NSF ERC       
Butler, Rm 300, PO Box 9637, Corner of Perry&Barr, Mississippi State,MS 39762 
(601)325-8435 FAX: (601)325-8997;  http://www.erc.msstate.edu/~tony; Quote:
"What a rain of ashes falls on him that sees the new and cannot leave the
old."-Shakespeare  ; e-mail: [email-masked];  Try MPI!