Subject: Re: complex. sigh.

From: Leslie Hart (NOAA/FSL) <[email-masked]>
Date: Tue, 19 Jul 1994 17:13:28 -0600

I'm no expert on ANSI Fortran, buy my Sun compiler will not
let me put a variable declared as complex in the MAX intrinsic.
Are we proposing to support something that the native language
would not define?

      program t1
      complex a, b, c
      a = (1, 1)
      b = (2, -1)
      c = max (a, b)
      print *, a, b, c
      end
"f.f", line 5: Error: bad argument type to intrinsic "max"

Leslie

---

From: Bob Knighten <[email-masked]>
Date: Tue, 19 Jul 94 17:17:27 PDT

Neither Fortran 77 nor Fortran 90 suport COMPLEX arguments for the MAX or MIN
intrinsic.  

I have no objection to the proposal, but I was puzzled by the claim that this
is fundamental in Fortran and equally surprised by the description of the
proposed rule for breaking "ties" as a "stable sort requirement".  MAX and MIN
do NOT have a natural meaning for the COMPLEX type.

-- Bob

-- 
Robert L. Knighten	             | [email-masked]
Intel Supercomputer Systems Division | 
CO1-05                               |
15201 N.W. Greenbrier Pkwy.	     | (503) 629-4315
Beaverton, Oregon  97006	     | (503) 629-9147 [FAX]

---

From: [email-masked] (James Cownie)
Date: Wed, 20 Jul 1994 09:39:29 +0000

> Neither Fortran 77 nor Fortran 90 suport COMPLEX arguments for the MAX or MIN

Nor for the MINVAL and MAXVAL intrinsics in F90 (which apply to
arrays, rather than scalars).

On these grounds there is no need to make this extension (which seems
to be contentious).

-- Jim 
James Cownie 
Meiko Limited			Meiko Inc.
650 Aztec West			130C Baker Avenue Ext.
Bristol BS12 4SD		Concord
England				MA 01742

Phone : +44 454 616171		+1 508 371 0088
FAX   : +44 454 618188		+1 508 371 7516
E-Mail: [email-masked]   or    [email-masked]
WWW   : http://www.meiko.com:8080/welcome.html

---

From: [email-masked] (Joel Williamson)
Date: Wed, 20 Jul 94 6:59:12 CDT

> On these grounds there is no need to make this extension (which seems

There's an interesting article in (I think) this month's Discover
magazine, discussing metrics that reduce to a single number.  In the
introduction it is pointed out that there is no way to order the points
on a plane, and that any attempt to map the plane to a line where
ordering makes sense is simply a matter of taste.

Joel Williamson